In Files

  • rubygems/dependency_resolver.rb

Class/Module Index [+]

Quicksearch

Gem::ImpossibleDependenciesError

Raised when dependencies conflict and create the inability to find a valid possible spec for a request.

Attributes

conflicts[R]

Public Class Methods

new(request, conflicts) click to toggle source
 
               # File rubygems/dependency_resolver.rb, line 45
def initialize(request, conflicts)
  s = conflicts.size == 1 ? "" : "s"
  super "detected #{conflicts.size} conflict#{s} with dependency '#{request.dependency}'"
  @request = request
  @conflicts = conflicts
end
            

Public Instance Methods

dependency() click to toggle source
 
               # File rubygems/dependency_resolver.rb, line 52
def dependency
  @request.dependency
end
            

Commenting is here to help enhance the documentation. For example, code samples, or clarification of the documentation.

If you have questions about Ruby or the documentation, please post to one of the Ruby mailing lists. You will get better, faster, help that way.

If you wish to post a correction of the docs, please do so, but also file bug report so that it can be corrected for the next release. Thank you.

If you want to help improve the Ruby documentation, please visit Documenting-ruby.org.

blog comments powered by Disqus