In Files

  • rubygems/errors.rb

Methods

Class/Module Index [+]

Quicksearch

Gem::ConflictError

Raised when there are conflicting gem specs loaded

Attributes

conflicts[R]

A Hash mapping conflicting specifications to the dependencies that caused the conflict

target[R]

The specification that had the conflict

Public Class Methods

new(target, conflicts) click to toggle source
 
               # File rubygems/errors.rb, line 83
def initialize target, conflicts
  @target    = target
  @conflicts = conflicts
  @name      = target.name

  reason = conflicts.map { |act, dependencies|
    "#{act.full_name} conflicts with #{dependencies.join(", ")}"
  }.join ", "

  # TODO: improve message by saying who activated `con`

  super("Unable to activate #{target.full_name}, because #{reason}")
end