class Gem::Specification

On universal Rubies, resolve the “universal” arch to the real CPU arch, without changing the extension directory.

Constants

LATEST_RUBY_WITHOUT_PATCH_VERSIONS
ORIGINAL_LOCAL_PLATFORM

Attributes

location[RW]
relative_loaded_from[RW]
remote[RW]
source[W]

Public Instance Methods

deleted_gem?() click to toggle source
# File bundler/rubygems_ext.rb, line 132
def deleted_gem?
  !default_gem? && !File.directory?(full_gem_path)
end
extension_dir() click to toggle source
# File bundler/rubygems_ext.rb, line 67
def extension_dir
  @bundler_extension_dir ||= if source.respond_to?(:extension_dir_name)
    unique_extension_dir = [source.extension_dir_name, File.basename(full_gem_path)].uniq.join("-")
    File.expand_path(File.join(extensions_dir, unique_extension_dir))
  else
    rg_extension_dir
  end
end
Also aliased as: rg_extension_dir
extensions_dir() click to toggle source
# File bundler/rubygems_ext.rb, line 324
def extensions_dir
  Gem.default_ext_dir_for(base_dir) ||
    File.join(base_dir, "extensions", ORIGINAL_LOCAL_PLATFORM,
              Gem.extension_api_version)
end
full_gem_path() click to toggle source
# File bundler/rubygems_ext.rb, line 46
def full_gem_path
  if source.respond_to?(:root)
    Pathname.new(loaded_from).dirname.expand_path(source.root).to_s.tap {|x| x.untaint if RUBY_VERSION < "2.7" }
  else
    rg_full_gem_path
  end
end
Also aliased as: rg_full_gem_path
gem_dir() click to toggle source
# File bundler/rubygems_ext.rb, line 77
def gem_dir
  full_gem_path
end
git_version() click to toggle source
# File bundler/rubygems_ext.rb, line 102
def git_version
  return unless loaded_from && source.is_a?(Bundler::Source::Git)
  " #{source.revision[0..6]}"
end
groups() click to toggle source
# File bundler/rubygems_ext.rb, line 98
def groups
  @groups ||= []
end
load_paths() click to toggle source
# File bundler/rubygems_ext.rb, line 62
def load_paths
  full_require_paths
end
loaded_from() click to toggle source
# File bundler/rubygems_ext.rb, line 54
def loaded_from
  if relative_loaded_from
    source.path.join(relative_loaded_from).to_s
  else
    rg_loaded_from
  end
end
Also aliased as: rg_loaded_from
nondevelopment_dependencies() click to toggle source
# File bundler/rubygems_ext.rb, line 128
def nondevelopment_dependencies
  dependencies - development_dependencies
end
required_ruby_version=(req) click to toggle source
# File bundler/rubygems_ext.rb, line 85
def required_ruby_version=(req)
  self.rg_required_ruby_version = req

  @required_ruby_version.requirements.map! do |op, v|
    if v >= LATEST_RUBY_WITHOUT_PATCH_VERSIONS && v.release.segments.size == 4
      [op == "~>" ? "=" : op, Gem::Version.new(v.segments.tap {|s| s.delete_at(3) }.join("."))]
    else
      [op, v]
    end
  end
end
rg_extension_dir()
Alias for: extension_dir
rg_full_gem_path()
Alias for: full_gem_path
rg_loaded_from()
Alias for: loaded_from
source() click to toggle source
# File bundler/rubygems_ext.rb, line 39
def source
  (defined?(@source) && @source) || Gem::Source::Installed.new
end
to_gemfile(path = nil) click to toggle source
# File bundler/rubygems_ext.rb, line 107
def to_gemfile(path = nil)
  gemfile = String.new("source 'https://rubygems.org'\n")
  gemfile << dependencies_to_gemfile(nondevelopment_dependencies)
  unless development_dependencies.empty?
    gemfile << "\n"
    gemfile << dependencies_to_gemfile(development_dependencies, :development)
  end
  gemfile
end