Support for the Ruby 2.2 series has ended. See here for reference.

In Files

  • zlib/zlib.c

Parent

Zlib::NeedDict

Subclass of Zlib::Error

When zlib returns a Z_NEED_DICT if a preset dictionary is needed at this point.

Used by Zlib::Inflate.inflate and Zlib.inflate