Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • tk/lib/tkextlib/tcllib/dateentry.rb

Class/Module Index [+]

Quicksearch

Tk::Tcllib::Widget::DateEntry

Public Class Methods

package_name() click to toggle source
 
               # File tk/lib/tkextlib/tcllib/dateentry.rb, line 19
def self.package_name
  PACKAGE_NAME
end
            
package_version() click to toggle source
 
               # File tk/lib/tkextlib/tcllib/dateentry.rb, line 23
def self.package_version
  begin
    TkPackage.require('widget::dateentry')
  rescue
    ''
  end
end
            

Public Instance Methods

post() click to toggle source
 
               # File tk/lib/tkextlib/tcllib/dateentry.rb, line 53
def post
  tk_send('post')
  self
end
            
unpost() click to toggle source
 
               # File tk/lib/tkextlib/tcllib/dateentry.rb, line 58
def unpost
  tk_send('unpost')
  self
end