Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • xmlrpc/parser.rb

XMLRPC::XMLParser::XMLTreeParser

Public Class Methods

new() click to toggle source
 
               # File xmlrpc/parser.rb, line 645
def initialize
  require "xmltreebuilder"

  # The new XMLParser library (0.6.2+) uses a slightly different DOM implementation.
  # The following code removes the differences between both versions.
  if defined? XML::DOM::Builder
    return if defined? XML::DOM::Node::DOCUMENT # code below has been already executed
    klass = XML::DOM::Node
    klass.const_set(:DOCUMENT, klass::DOCUMENT_NODE)
    klass.const_set(:TEXT, klass::TEXT_NODE)
    klass.const_set(:COMMENT, klass::COMMENT_NODE)
    klass.const_set(:ELEMENT, klass::ELEMENT_NODE)
  end
end