Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • webrick/httpauth/authenticator.rb

WEBrick::HTTPAuth::Authenticator

Module providing generic support for both Digest and Basic authentication schemes.

Constants

AuthScheme

Method of authentication, must be overridden by the including class

Attributes

logger[R]

The logger for this authenticator

realm[R]

The realm this authenticator covers

userdb[R]

The user database for this authenticator