Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • shell/builtin-command.rb

Shell::Echo

Public Class Methods

new(sh, *strings) click to toggle source
 
               # File shell/builtin-command.rb, line 35
def initialize(sh, *strings)
  super sh
  @strings = strings
end
            

Public Instance Methods

each(rs = nil) click to toggle source
 
               # File shell/builtin-command.rb, line 40
def each(rs = nil)
  rs =  @shell.record_separator unless rs
  for str  in @strings
    yield str + rs
  end
end