Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • rubygems/exceptions.rb

Parent

Methods

Class/Module Index [+]

Quicksearch

Gem::SystemExitException

Raised to indicate that a system exit should occur with the specified #exit_code

Attributes

exit_code[RW]

The exit code for the process

Public Class Methods

new(exit_code) click to toggle source

Creates a new SystemExitException with the given exit_code

 
               # File rubygems/exceptions.rb, line 205
def initialize(exit_code)
  @exit_code = exit_code

  super "Exiting RubyGems with exit_code #{exit_code}"
end