Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • rubygems/request_set/lockfile.rb

Methods

Class/Module Index [+]

Quicksearch

Gem::RequestSet::Lockfile::ParseError

Raised when a lockfile cannot be parsed

Attributes

column[R]

The column where the error was encountered

line[R]

The line where the error was encountered

path[R]

The location of the lock file

Public Class Methods

new(message, column, line, path) click to toggle source

Raises a ParseError with the given message which was encountered at a line and column while parsing.

 
               # File rubygems/request_set/lockfile.rb, line 34
def initialize message, column, line, path
  @line   = line
  @column = column
  @path   = path
  super "#{message} (at line #{line} column #{column})"
end