Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • rubygems/exceptions.rb

Class/Module Index [+]

Quicksearch

Gem::ImpossibleDependenciesError

Raised by Gem::Resolver when dependencies conflict and create the inability to find a valid possible spec for a request.

Attributes

conflicts[R]
request[R]

Public Class Methods

new(request, conflicts) click to toggle source
 
               # File rubygems/exceptions.rb, line 128
def initialize request, conflicts
  @request   = request
  @conflicts = conflicts

  super build_message
end
            

Public Instance Methods

dependency() click to toggle source
 
               # File rubygems/exceptions.rb, line 149
def dependency
  @request.dependency
end