Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • rubygems/exceptions.rb

Class/Module Index [+]

Quicksearch

Gem::DependencyResolutionError

Raised by Gem::Resolver when a Gem::Dependency::Conflict reaches the toplevel. Indicates which dependencies were incompatible through conflict and conflicting_dependencies

Attributes

conflict[R]

Public Class Methods

new(conflict) click to toggle source
 
               # File rubygems/exceptions.rb, line 34
def initialize conflict
  @conflict = conflict
  a, b = conflicting_dependencies

  super "conflicting dependencies #{a} and #{b}\n#{@conflict.explanation}"
end
            

Public Instance Methods

conflicting_dependencies() click to toggle source
 
               # File rubygems/exceptions.rb, line 41
def conflicting_dependencies
  @conflict.conflicting_dependencies
end