Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • rubygems/commands/outdated_command.rb

Class/Module Index [+]

Quicksearch

Gem::Commands::OutdatedCommand

Public Class Methods

new() click to toggle source
 
               # File rubygems/commands/outdated_command.rb, line 11
def initialize
  super 'outdated', 'Display all gems that need updates'

  add_local_remote_options
  add_platform_option
end
            

Public Instance Methods

execute() click to toggle source
 
               # File rubygems/commands/outdated_command.rb, line 27
def execute
  Gem::Specification.outdated_and_latest_version.each do |spec, remote_version|
    say "#{spec.name} (#{spec.version} < #{remote_version})"
  end
end