Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • rss/utils.rb

Methods

Class/Module Index [+]

Quicksearch

RSS::Utils::CSV

Public Instance Methods

parse(value, &block) click to toggle source
 
               # File rss/utils.rb, line 158
def parse(value, &block)
  if value.is_a?(String)
    value = value.strip.split(/\s*,\s*/)
    value = value.collect(&block) if block_given?
    value
  else
    value
  end
end