Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • rss/1.0.rb

Parent

Namespace

Included Modules

Class/Module Index [+]

Quicksearch

RSS::TaxonomyTopicsModel::TaxonomyTopics::Bag

Constants

Li

Public Class Methods

new(*args) click to toggle source
 
               # File rss/1.0.rb, line 174
def initialize(*args)
  if Utils.element_initialize_arguments?(args)
    super
  else
    super()
    @li = args[0] if args[0]
  end
end
            
required_uri() click to toggle source
 
               # File rss/1.0.rb, line 164
def required_uri
  URI
end
            

Public Instance Methods

full_name() click to toggle source
 
               # File rss/1.0.rb, line 183
def full_name
  tag_name_with_prefix(PREFIX)
end
            
setup_maker(target) click to toggle source
 
               # File rss/1.0.rb, line 187
def setup_maker(target)
  lis.each do |li|
    target << li.resource
  end
end