Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • rss/maker/2.0.rb

Class/Module Index [+]

Quicksearch

RSS::Maker::RSS20::Items::Item::Enclosure

Public Instance Methods

to_feed(rss, item) click to toggle source
 
               # File rss/maker/2.0.rb, line 130
def to_feed(rss, item)
  enclosure = Rss::Channel::Item::Enclosure.new
  set = setup_values(enclosure)
  if set
    item.enclosure = enclosure
    set_parent(enclosure, item)
    setup_other_elements(rss, enclosure)
  end
end