Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • rss/maker/1.0.rb

Parent

Class/Module Index [+]

Quicksearch

RSS::Maker::RSS10::Textinput

Public Instance Methods

have_required_values?() click to toggle source
 
               # File rss/maker/1.0.rb, line 421
def have_required_values?
  super and @maker.channel.have_required_values?
end
            
to_feed(rss) click to toggle source
 
               # File rss/maker/1.0.rb, line 409
def to_feed(rss)
  if @link
    textinput = RDF::Textinput.new(@link)
    set = setup_values(textinput)
    if set
      rss.textinput = textinput
      set_parent(textinput, rss)
      setup_other_elements(rss, textinput)
    end
  end
end