Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • rss/maker/1.0.rb

Class/Module Index [+]

Quicksearch

RSS::Maker::RSS10::Items::Item

Public Instance Methods

to_feed(rss) click to toggle source
 
               # File rss/maker/1.0.rb, line 233
def to_feed(rss)
  set_default_values do
    item = RDF::Item.new(link)
    set = setup_values(item)
    if set
      item.dc_dates.clear
      rss.items << item
      set_parent(item, rss)
      setup_other_elements(rss, item)
    elsif !have_required_values?
      raise NotSetError.new("maker.item", not_set_required_variables)
    end
  end
end