Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • rss/maker/0.9.rb

Parent

Methods

Class/Module Index [+]

Quicksearch

RSS::Maker::RSS09::Image

Public Instance Methods

to_feed(rss) click to toggle source
 
               # File rss/maker/0.9.rb, line 224
def to_feed(rss)
  image = Rss::Channel::Image.new
  set = setup_values(image)
  if set
    image.link = link
    rss.channel.image = image
    set_parent(image, rss.channel)
    setup_other_elements(rss, image)
  elsif required_element?
    raise NotSetError.new("maker.image", not_set_required_variables)
  end
end