Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • psych/lib/psych/visitors/json_tree.rb

Parent

Methods

Psych::Visitors::JSONTree

Public Class Methods

create(options = {}) click to toggle source
 
               # File psych/lib/psych/visitors/json_tree.rb, line 8
def self.create options = {}
  emitter = Psych::JSON::TreeBuilder.new
  class_loader = ClassLoader.new
  ss           = ScalarScanner.new class_loader
  new(emitter, ss, options)
end
            

Public Instance Methods

accept(target) click to toggle source
 
               # File psych/lib/psych/visitors/json_tree.rb, line 15
def accept target
  if target.respond_to?(:encode_with)
    dump_coder target
  else
    send(@dispatch_cache[target.class], target)
  end
end