Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • psych/lib/psych/streaming.rb

Methods

Psych::Streaming

Public Instance Methods

start(encoding = Nodes::Stream::UTF8) click to toggle source

Start streaming using encoding

 
               # File psych/lib/psych/streaming.rb, line 17
def start encoding = Nodes::Stream::UTF8
  super.tap { yield self if block_given?  }
ensure
  finish if block_given?
end