Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • psych/lib/psych/handler.rb

Parent

Methods

Psych::Handler::DumperOptions

Configuration options for dumping YAML.

Attributes

canonical[RW]
indentation[RW]
line_width[RW]

Public Class Methods

new() click to toggle source
 
               # File psych/lib/psych/handler.rb, line 18
def initialize
  @line_width  = 0
  @indentation = 2
  @canonical   = false
end