Support for the Ruby 2.1 series ended on March 31 2017. See here for details.

In Files

  • psych/lib/psych/core_ext.rb
  • psych/lib/psych/deprecated.rb

Parent

Object

Public Class Methods

yaml_tag(url) click to toggle source
 
               # File psych/lib/psych/core_ext.rb, line 2
def self.yaml_tag url
  Psych.add_tag(url, self)
end
            

Public Instance Methods

to_yaml(options = {}) click to toggle source

Convert an object to YAML. See Psych.dump for more information on the available options.

 
               # File psych/lib/psych/core_ext.rb, line 13
def psych_to_yaml options = {}
  Psych.dump self, options
end
            
Also aliased as: to_yaml
to_yaml(options = {}) click to toggle source
Alias for: psych_to_yaml