In Files

  • rubygems/dependency_resolver.rb

Class/Module Index [+]

Quicksearch

Gem::ImpossibleDependenciesError

Raised when dependencies conflict and create the inability to find a valid possible spec for a request.

Attributes

conflicts[R]

Public Class Methods

new(request, conflicts) click to toggle source
 
               # File rubygems/dependency_resolver.rb, line 45
def initialize(request, conflicts)
  s = conflicts.size == 1 ? "" : "s"
  super "detected #{conflicts.size} conflict#{s} with dependency '#{request.dependency}'"
  @request = request
  @conflicts = conflicts
end
            

Public Instance Methods

dependency() click to toggle source
 
               # File rubygems/dependency_resolver.rb, line 52
def dependency
  @request.dependency
end