Extended maintenance of Ruby versions 1.8.7 and 1.9.2 ended on July 31, 2014. Read more

In Files

  • error.c

Parent

SecurityError

Raised when attempting a potential unsafe operation, typically when the $SAFE level is raised above 0.

foo = "bar"
proc = Proc.new do
  $SAFE = 4
  foo.gsub! "a", "*"
end
proc.call

raises the exception:

SecurityError: Insecure: can't modify string